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THE FEEL OF CSS




INTRODUCTION

x Control System Studio
x Eclipse RCP based development platform
x Provides IDE for EPICS, TANGO, TINE...

x Can access different control systems in one
application

The Control System Studio (CSS) is an Eclipse RCP based development platform and the
fundament for many applications like EPICS, TANGO etc. As most of these applications deal
with process variables and connections to control systems, the CSS Core provides the
necessary APls for a convenient start.

The integrated development environment of CSS provides facility for database development,
aIarIm management system, display development and conversion, data trending, diagnostic
tools etc.

Process variable address syntax

The general syntax of a process variable address is defined as follows. This uses the
metasyntax based on the Extended Backus-Naur Form

[1] address ::= [protocol] id [type]

2] protocol ::= ('dal-epics' | 'dal-tine' | 'dal-tango' | 'local') "://'
3] id::= (letter | specialcharacter) +

4] type ::="', ' ('double’ | 'int' | 'long' | 'string' | 'enum’)

5] letter::="'A"| ... |'Z'|'a' | ... | 'Z'

[6] specialcharacter::="" | '/" |"\"| " | 'T"| "I

7] number ::= digitWithoutZero (digit)*

8] digit :='0" | ... | '9'

[9] digitWithoutZero ::="1"| ... | '9'

There are 3 optional and 1 mandatory fragments that constitute a full process variable
address (line 1).

The protocol (line 2) is optional and defines the connection protocol. If a prefix is not
specified, a default protocol is chosen according to the settings of the CSS-Core/Control-
System preference page.

The id (line 3) is mandatory. It must be a globally unique name identifying the information
you want to address.

The type (line 5) is optional, too. It can be used to specify the expected return type for
channel values explicitly.



INTRODUCTION

x Control System Studio
x Eclipse RCP based development platform
x Provides IDE for EPICS, TANGO, TINE...

x Can access different control systems in one
application

Syntax for EPICS
When EPICS channels are addressed, line 3 is as follows:
[3a] id::= recordname ['." fieldname] [characteristic]
[10] recordname ::= (letter | specialcharacter)+
[11] fieldname ::= (letter)+
[12] characteristic ::='[' (letter)+ ']’
An EPICS process variable is always identified by its recordname (line 10) which
is therefore mandatory.
Optionally a fieldname can be provided to address a single field of a record (line 11). If no fieldname is provided
the address defaults to the .VAL field.
The characteristic (line 12) is optional as well. If defined it allows for accessing additional information of a record
without establishing a new connection. All characteristics of the same record share the same connection. So in
general it is a good idea to use characteristics whenever possible to save system resources. These can be
[Position] - position
[Description] — long description
[displayName] — short description
[propertyType] - type
[resolution] — number of bits used for ADC conversion of analog value when sampled
[minimum] — minimum allowed value
[maximum] — maximum allowed value
[graphMin] — minimum allowed value when displayed (e.g. in a chart)
[graphMax] — maximum allowed value when displayed (e.g. in a chart)
[format] — C print-f style format that is used to render the value
[units] — units of the value
[scaleType] — scale type for plotting (linear or logarithmic)
[warningMax] — upper warning limit
[warningMin] — lower warning limit
[alarmMax] — upper alarm limit
[alarmMin] — lower alarm limit
[sequencelength] — sequence length
[enumValues] — enum value array (returns Object[])
[enumDescriptions] — enum value descriptions (returns String[])
[bitDescriptions] — bit descriptions (returns String[])
[conditionWhenSet] — active bit significance
[conditionWhenCleared] - inactive bit significance
[bitMask] — bits relevance



INTROD

/"_.‘ o N/ 7—_ -.,\\ /"'_” T
i EPICS ) | TINE [ TANGO
. rd AN )

-\.
]
A

i / T ESE Core
A I//': IMULATOR:

CAJ ISSsaiaaaasnannan=_0g \;Mu )
B
| DAL

}> SmIe - F__J\’_jgl/

0 .

r A

| CSS Applications |

Simple DAL allows to use a certain syntax for accessing PVs.

The Data Access Layer (DAL) is the core of the connection APIs. It
communicates to EPICS through CAJ (Channel Access Java), which is a
pure Java implementation of the CA protocol. In the (near) future it will
be possible to connect to TINE and TANGO control systems through DAL
as well. ATINE integration is already available as Beta. DAL is an inherent
part of the CSS Core but can also be used as a library in any other Java
application. SimpleDAL is a connection layer built on top of DAL. It
provides a slim, less complex API that allows for a much easier start for
developers dealing with process variables in their applications. Using
SimpleDAL implies a certain syntax for process variable addresses that
enables applications to make use of the following features:

e access different control systems (e.g. TINE and EPICS) in one application
e use characteristics, a concept for resource saving access to record fields
e query process variables in different types

¢ use simulated channels

e address system functions as process variable



DOWNLOADING & INSTALLATION

x Versions: Standard, SNS, DESY
Pre-requisite: Java 1.6 or higher

Download according to OS from: http://css.desy.de/content/
e413/index_eng.html

Extract the archive to directory of your choice
Start CSS

Windows: css.exe

Linux: set execute mode for file “css” and run

Login: Cancel the login, you will be logged in as

anonymous. (XMPP used for remote management, You
can setup your own)

X X

X + + X %

It is recommended that the standard version of CSS should be
downloaded for the first use. It consists of the CSS platform and common
control system applications.

Pre-requisites - Java version 1.6 or higher is required
Download - The link to this is
http://css.desy.de/content/e413/index_eng.html| Please choose the
version according to your operating system.
Extracting — extract the downloaded zip file in a directory of your choice.
Starting
Windows — Run the file css.exe under CSS <Top>.
Linux — Set executable mode for the file ‘css’ under CSS <top> and
run
Login - The XMPP login can be cancelled for initial use. This logins you as
anonymous user into the XMPP server specified in the preferences. The
XMPP server is used for remote management. One can also set up his
own XMPP server.




CSS BASICS

x Console

x Menu bar
+ File...
+ CSS...
+ Quickstart...
+ Window...
+ Help...

CSS Console
The CSS contains its own console. This console display system messages of certain events and information about
occurred errors.

File

New - Create a new folder, resource,

Switch Workspace - Change the workspace of the CSS instance.

Export preferences - Write current preferences of the CSS instance in a file.
Open Workspace Navigator - Open the view 'Workspace'.

Import - Import resource from CVS in the workspace.

Exit - Shut down your CSS installation.

Quickstart - The Quickstart menu holds links to Synoptic Displays in the workspace. They can be added via context
menu of a display.

Window

Open in New Window - Open a new CSS window.

Open Perspective - Select and open a particular CSS perspective. In the CSS context, a perspective is a set of user
interface elements that are positioned in a certain way.

Show View - Open a particular CSS view. In the CSS context, a view is an element of the user interface that displays
something and can be freely arranged by the user.

Help

Welcome

About CSS - Open the “About” dialog that contains the CSS license agreement.

Help Contents - Open the CSS help system. There you may find a more detailed description of the basic user
interface concepts and all system settings.

Key Assist - Open an overview of all shortcuts.

Cheat Sheets - Shows available Cheat Sheets. Cheat Sheets are step by step documentations.

Software Updates - Manage the local CSS installation by installing and updating features. -> find and install ->
search for new features to install



SETTING EPICS PREFERENCES |

x Used to specify the EPICS |OC location and
other attributes

x Go to CSS Menu -> CSS -> Preferences -> CSS
core -> Control system

x Set the default control system as EPICS
x Under ‘CSS core’ menu item, go to ‘EPICS’
x Set the EPICS preferences here.

eUsed to specify the EPICS I0C location and other attributes

*Go to CSS Menu -> CSS -> Preferences -> CSS core -> Control system
eSet the default control system as EPICS

eUnder ‘CSS core’ menu item, go to ‘EPICS’

eSet the EPICS preferences here.



LOADING CSS PLUG-INS

x Go to CSS menu -> Help -> Software updates -> Find and
Install

Select “Select for new features to install”

Select the check box for “Control system studio update site”
Click “Finish”

Expand the tree for “Control system studio update site”

Select the plugin you want to install and click “select
required” button.

Go “next” and accept license agreement.
x Next and click “Finish”

x The installed plugin will now appear in the CSS menu under
appropriate category

X X X X X

X

CSS plugins are the various tools available with it. To add these into the CSS:

*Go to CSS menu -> Help -> Software updates -> Find and Install

eSelect “Select for new features to install”

eSelect the check box for “Control system studio update site”

¢Click “Finish”

eExpand the tree for “Control system studio update site”

eSelect the plugin you want to install and click “select required” button.

*Go “next” and accept license agreement.

eNext and click “Finish”

eThe installed plugin will now appear in the CSS menu under appropriate category
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CSS GENERAL

x Open workspace navigator

x New -> Project -> Save as

x Right click on the project

x New -> Other -> General -> Folder
x Make your own file here

To make a new project

*Go to File -> New -> other -> General -> Project
*Name the project

eYou can make new folders or files inside a project

*To make a folder, right click the project in the navigator -> New -> other -> General ->
folder
*To make a new file, right click the project in the navigator -> New -> other -> choose

accordingly
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SDS - SYNOPTIC DISPLAY STUDIO

Synoptic Display Studio

Synoptic Display Studio (SDS) is a graphical operator interface that represents the
structure and current state of a plant. The structure is composed of basic elements so
called widgets like labels, meters or bargraphs. To build up a part of a plant the
widgets can be arranged in the edit mode of SDS on displays. In the execute or run
mode the operators can control the processes via the displays.

Navigator

The navigator view shows the CSS projects in the workspace. A CSS project holds the
configuration files for SDS displays and files of other CSS applications.

Editor / Palette

The Editor shows the displays in the edit mode and provides grid, align, ruler, etc. On
the right side is the palette with all available widgets. There is a drag and drop
support that connects a process variable from another CSS application automatically
with a widget.

Widget Properties

For each selected widget in the editor the widget property view shows all available
properties. It is possible to dynamise *LINK* each property. That means that a
property is connected to a process variable and changes with the value of the
variable.

12



OVERVIEW

Open a new SDS file
Open palette, widget properties
Select a widget, use dot to enable movement through arrow keys
Menu bar for arranging widgets
Click on a property on the Property View to set a static property.
+ Enter a text
+ Enter a number
+ Choose a color
+ Choose a font
+ Set a boolean
+ Select a combo item
x And three special editors:
+ Add / change aliases
+ Add / change actions
x Multiselect widget shows common properties to edit (Ctrl+Select)

X X X X X

There are two kinds of property
eStatic- fixed during execution mode
eDynamic — changes during execution mode

Single left click on a property on the Property View to set a static property.

Single left click on a property opens an editor. There are six general editors:
-- Enter a text

-- Enter a number

-- Choose a color

-- Choose a font

-- Set a boolean

-- Select a combo item

And three special editors:
-- Add / change aliases

-- Add / change actions

-- Generate tooltip
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*Open the Layer Management Menu:

Window -> Show View -> Other... -> Synoptic Display Studio -> Layer Management
e|nside the layer management view, right click to add new layer, or move existing
oVisibility and order of a layer can be changed
e Visibility of a layer can be toggled dynamically
eRight click a widget to change its layer
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DYNAM ICS “ Text Yalue

x The property with such symbol is dynamic

x Right click on property to configure or remove
dynamic aspects

x Channel name can be typed directly
x Alias can be used instead of a PV name
x Each widget has Primary PV

+ Copy PV to clipboard

+ Forwarded to the applications called by contribution
menu

+ Tip text

eThe property with ‘gear wheel’ symbol is dynamic
*Right click on property to configure or remove dynamic aspects
eChannel name can be typed directly
eAlias can be used instead of a PV name
eDynamic properties can be configured by rules (explained later)
eEach widget has a Primary PV, it is used when you use
eCopy PV to clipboard
eForwarded to the applications called by contribution menu
oTip text
So it is necessary to define a primary PV
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ALIAS

x Alias is a macro used for the long PV syntax
x Each widget can have several aliases
x Alias can be forwarded to a new display

eAlias is a macro that can be used instead of long PV name or syntax

eEach widget can have several aliases ( e.g. for displaying several plots on strip chart)
eAlias can be forwarded to a new display

16



CONNECTION AND CONDITION STATES |

x Color can be customized for these

x Right click on background color properties to
configure dynamic aspects

x Next
x Colors can be set here
x Try out

eColor can be customized for these

eRight click on background color properties to configure dynamic aspects
*Go to Next

eColors can be set here
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RULES

x Rules can be used to define the dynamic
behavior of widget properties

x Two types
+ Java
+ Script

x Scripted rule files should be kept at ‘SDS Script
Rules’ folder under the workspace

*Rules can be used to define the dynamic behavior of widget properties
eThere are two types of rules

eJava

*ECMA/Java Script
eScripted rule files should be kept at ‘SDS Script Rules’ folder under the workspace
e|t is recommended that JavaScript rules should be used for configuring dynamic
properties instead of Java, as no compilation is needed in this case

18



ACTION DATA

x There are two kinds of action data
+ Send a value
+ Open another display

x Each widget can have arbitrary no. of action
data

x Action can be executed from the contribution
menu as well

Action data setting defines the action which is performed when a widget is activated
(i.e say a button is clicked)

Actions can be of two types
eSending value
*Open a display

Each widget can have arbitrary no. of action data
Action can be executed from the contribution menu as well. The contribution menu is

invoked by right clicking a widget -> CSS ->
<contribution menu>

19



CURSOR

x Cursor can be changed as the mouse pointer
moves over some widget

x System cursors
x Other - action enabled, action disabled

Cursor can be changed as the mouse pointer moves over some widget
Widget properties have a field for changing cursor
There are two kind of cursors

1.System cursors
2.0ther — action enabled, action disabled

20



WIDGET OVERVIEW

x Polyline/polygon

Important Properties:
- Line Width
- Line Style

Special Properties:
- Rotation

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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WIDGET OVERVIEW

Rectangle/ellipse/arc

Special Properties:
- Horizontal Orientation
-Value

Special Properties:
- Horizontal Orientation
- Value
\ Special Properties:
- Start Angle

-Angle
-Filled

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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WIDGET OVERVIEW

Label/ text input

_ Special Properties:
- TextValue
- Text Rotation Angle
L el ¥ offeet
- Y Offset
_ Impeortant Properties:
- Text Alignment

fichannel=}]
_ Special Properties:
= Input Text

_ Important Properties:
- Text Alignment

e T

Number format

see also the ToolTip

Note:

- Value Type

- dynamic value type addition

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf



WIDGET OVERVIEW

Simple slider / Advanced slider

simple Siider Label

Important Properties:

= Slider Value { }

-Increment o

= Max

=Min | Advanced Slider Label
]| ——
4 | | » | I0C: 50.0

— MaN: 50.0

Special Properties:
- Horizontal orientation
- Show Value As Text

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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WIDGETOVERVIEW

Action button / Menu button

Important Properties:

- Action Data

-Label Text

Special Properties:

Label - Action Index (released)
- Action Index (pressed)
- Toggel Button

Important Properties:
Lakel - Action Data
-Label Text

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf



Bargraph / Meter
____ I

LOLO Lo HL HIHT
LoLo Lo HL HIHI

Important Properties:
-Value

Special Properties:
-Level HIHI

-Level HIGH

-Level LOW

-Level LOLO

- Minimum (LOPR)
-Maximum (HOPR) |
- Scale

- Section Count

- Show only value

- Tickmarks

Trainloc: Alarm R AMPE_calc

WIDGETOVERVIEW

Important Properties:
=Value

Special Properties:

- Boundary [ Color HIHI
- Boundary [ Color HIGH
- Boundary [ Color LOW
- Boundary [ Color LOLO
- Minimum (LOPR)

- Maximum (HOPR)

- Minor Scale Step

- Major Scale Step

- Display Angel

- Inner Angel

-Needle Color

- Scale Radius

- Scale Text Radius

- Scale With

- Visible Radius

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf

26



WIDGET OVERVIEW

Grouping Container

Grouping container/ Linking container

31.00

$channeld
Button

Itis possibel that a group is empty.
So it will rember it's properties.

All Widget ¢an be grouped.
A Group can have an Action.
A Group can be dynamic.

A Linking Container contains a Display defined by a rule.

Special Properties:
- Resource (¢an be dynamic)
= Automatic Zoom

Choose Faceplate

T2, Faceplate 0
¥4, Faceplate 1
3 %4, Faceplate 2
T2, Faceplate 3

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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WIDGET OVERVIEW

16 bit binary wheel / Thumb wheel

Important Properties:
-Value

Special Properties:

- Bit Range (from)

- Bit Range (to)

- Off Color

-On Color

- Show labels

LValue 0250.0010

Special Properties:
v v wviwv wiwvwvw

Important Properties: (‘lA‘wA’iAlA[A' -~

-Decimal digits

- Integer digits

-Min

-Max

-Internal frame thickness

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf



WIDGET OVERVIEW

Strip Chart / Waveform

67—

Important Properties:
- Automatic scaling

= Minimum

- Maximum 67—
Special Properties: |

Strip Chart

- Data point drawing 0 25||:| 200
style

= Graph line width
- Graph line color
-Labeled ticks

- Show axes

- X-achse label

- Y-achse label

- Y-achse scaling

T
150

T
100

pecial Properties:

- Update interval (sec)
- X-axis timespan (sec)
-Value #1to #8
-Enable plot  #1to #8
- Plot color #1to #8

5

Waveform

pecial Properties:

-Line chart
-Data #1to #4
- Plot color #1to #4

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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WID

x Switch

- Rotation

- Switch Type
- Switch State

Important Properties:
-Line Width

; E Special Properties:

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf



WID

x Timer
Siren OpenlClose Display
on | oft | on [ oft |
| Erter Text! ‘ | Enter Text! |

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf



WIDGET OVERVIEW

x Image

Special Properties:
- File

- Crop Bottom

- Crop Left

- Crop Rigth
-Crop Top

( I

contrel gystem studio

@

Images can be loaded
dynamically via seript
rules

Detailed documentation is found at

http://css.desy.de/content/e1576/e2369/SDS_Widgets V0.10-1.pdf
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UTILITIES

x Default display

x Quickstart

x Add to quickstart

x How to start quickstart entry
x Edit preferences

Default display is the default SDS file which opens through the contribution menu
(open display)

. To set the default display go to main menu -> CSS -> Preferences -> CSS

Applications -> Display -> Default Display

. Set the default file and the alias name

Quickstart menu is used to add shortcut to run the SDS files directly.

. The SDS files added to quickstart menu will directly open in execute mode

. To add files to quickstart menu, right click the SDS file in navigator pane -> add to
quickstart

. To invoke displays directly from quickstart, go to main menu -> quickstart -> (click
file name)

. To edit quickstart preferences go to main menu -> CSS -> Preferences -> CSS
Applications -> Utilities -> Quickstart
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ADL CONVERTER

= console 1 widget Prope... | &% ADL Converter 23— 3

Source

x ADL Converter is a tool to convert MEDM/
DM2K files to CSS-SDS files.

1. To start ADL converter, go to main menu -> CSS
-> Display -> ADL Converter

2. Click ‘File’ to upload MEDM/DM2K file (.adl

file)

Select path of directory for the destination file

(i.e for the css-sds file)

4. Click convert

5. Multiple files can be converted at once P

6. Add multiple files by above procedure, or add -

Remove lesding paits of path

folder which contains multiple files (Subfolder;) | ©

w

[_rie ][ suoider; | clesrm

Not lcgged in

What is the ADL Converter
The ADL Converter is a CSS Plugln that converts Control System Displays. This converts

only from ADL-Format to the Synoptic Display Studio format from the Control System
Studio.

Use the ADL Converter

The handling of the ADL Converter is very simple. First click the “File" button to
choose the ADL-Files which you want to convert. The chosen files are displayed at the
list and are all selected. Second click the "Select Path" button to choose the target
path at the Workspace. And at last click the "Convert" button to convert the ADL-
Files. Only the selected Files in the list are converted.

New Conversion
To convert other set of ADL-Files, clear the list by "Clear" button and choose the new
ADL-Files and a new target workspace path. Then start the new conversion
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PV TABLE

The PV Table provides a tabular view of PV names and their current value. One can
start and stop live value updates. In addition, one can take a "snapshot" of current
values, which gets saved when saving the PV table document. The PV table display
indicates current values that differ from the "snapshot" values in red.

One can configure the update rate as well as the threshold for indicating differences
between the current values and those from the snapshot.

To start with PV table

1.Go to main menu -> CSS -> Display -> PV Table

2.Right click the empty area in the table ->

3.Write the PV name to be monitored, go on adding names

4.A green LED symbol at the top icon bar is for starting the updates in PV table.
5.The update rate can be configured by right click on the PV table -> config
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PROBE

\ Probe G =5
PY Name: | EpicsDemol v m

Value: 46 Meter

Timestamp: 2010/02{22 11:30:39.384227340

Status:  Event period 0.1J seconds

Overview
The Probe tool allows basic reading and writing of PVs.

Usage

1.Enter a name into the PV name text box and enter. The tool will display the current
value of the given PV together with time stamp and status.

2.The 'Adjust' check box opens a dialog for writing a new value to the PV.

3.The status bar provides error messages. If all is OK, it displays a slowly averaged
update rate of the PV.

4.1t also displays alarm zones on the meter

5.The meter can be disabled also from the ‘Meter’ check box
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REFERENCES

x Information and documentation from http://
css.desy.de

x CSS help and training examples
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